Resources     Blog  

  1. Home
  2. WordPress Tutorials
  3. How to Downgrade WordPress to an Earlier Version

How to Downgrade WordPress to an Earlier Version

Did you know that it is possible to downgrade WordPress versions? While in the vast majority of situations, running the latest version of WordPress is the best option for your website, there may come a time when reverting to an older version may be more beneficial.

However, as you may expect, this is not a built-in feature of WordPress. Instead, you will need to use a plugin to downgrade your current version. Before you do anything in this tutorial, I strongly recommend creating a backup of your website.

Today, I will demonstrate how to with the WP Downgrade plugin.

When Should You Downgrade WordPress?

You should not revert WordPress to the previous version on a whim. There only a few very specific reasons it should be done. The most likely include:

  • If the latest version has broken something on your website.
  • If you must use a backup to restore your website, but the backup is from a previous version.
  • To downgrade an environment to an older version to perform tests.

There are other reasons, but these are by far the most common anyone will downgrade their current version of WordPress.Other than these, you should not revert your current version of WordPress.

Note: If you are a beginner, I do not recommend doing this at all. Downgrading WordPress, while easy to do, has a very high chance of messing up your website. Unless you have the proper knowledge of what other steps you need to do, like downgrading plugins, themes, and your PHP version, do not do it.

Why You Shouldn’t Downgrade A WordPress Version

It is very important to realize that when you roll back a WordPress update, you are making your website vulnerable. Every version update offers enhanced security that closes exploitations and keeps your website safe.

However, when you downgrade WordPress, your website is less secure. For this reason, it is not recommended to use an outdated version of WordPress.

Not only does this make your website less secure, but it may even cause themes and plugins to be incompatible if they are updated to their current version. This is because when a new version of WordPress rolls out, most plugins and themes also have an update.

This can break key features on your website and ultimately cause more harm than good in almost every situation.

Installing WP Downgrade

The WP Downgrade plugin serves one purpose, to downgrade your current WordPress version. It allows you to downgrade to any previous version of WordPress, and you can stay on it for as long as you want. However, it is highly recommended to avoid staying in an out-of-date version for a prolonged period of time.

The plugin is very simple to use, so let’s get right into it.

Click on Plugins and select the Add New option on the left-hand admin panel.

Add New

Search for WP Downgrade in the available search box. This will pull up additional plugins that you may find helpful.

WP Downgrade

Scroll down until you find the WP Downgrade plugin, click on the “Install Now” button and activate it for use.

Install Now

On the left-hand admin panel, click on Settings and select the WP Downgrade option. This will pull up the main settings page.

WP Downgrade

Note: Before going any further with this tutorial, I highly recommend creating a current backup of your website. WordPress was not designed to go back to older versions, so it is very likely that if you are picking a very old version, something will not work right.

Using WP Downgrade

The plugin could not be any easier to use. There is one text box to enter the version of WordPress that you want to revert back to.

For example, if you wanted to go back to version 5.0, you would enter 5.0. If you want to go back to version 5.13, you would enter 5.13.

Enter the desired WordPress version in the available text box.

Enter Version

Make sure the version is correct and click on the “Save Changes” button.

Save Changes

Click on the “Up-/Downgrade Core” button.

Downgrade Button

This will take you to the Updates section of WordPress. Click on the “Re-install Now” button.

Re-install Button

Your WordPress version will now revert to the one you selected in the previous step. You can change it to another version of WordPress by repeating these steps at any time.

Note:  If you decide to delete the plugin after it has served its purpose, you will be prompted to install the latest version of WordPress.

Congratulations on successfully downgrading your current version of WordPress with the WP Downgrade plugin.

An Alternative to Rollbacks

The most common reason someone will decide to rollback is when the latest version breaks something. However, this can be avoided entirely.

First, ensure that your automatic updates are turned off. Create a clone of your website and load it into a subdomain. This can be used as a testing environment.

Thus, when a new version of WordPress does come out, you can use this clone to install the latest version. And if everything works perfectly, you can let the update happen on your website.

If it does not go well, you can try to troubleshoot the problem in the testing environment, where it will not mess anything up. This saves you from having to go through the entire downgrade process altogether.

You Can Also Rollback Plugins And Themes

It is possible to assume that a core update broke a feature on your website, but it is far more likely for it to be the work of a plugin or a theme. You can use another plugin to rollback plugins and themes to a specific version.

In fact, if you are using an older version of WordPress, you may actually need to do this if you want a specific plugin to work.

Again, this is not recommended. Just like a WordPress version, this will make your website less safe. An older version of a plugin or theme will do the same thing. And it may even be more dangerous.

You May Need to Downgrade your PHP Version

Depending on how far back you decide to go with your version selection, you may need to change your current PHP version. Most web hosts will have your server installed with the latest PHP version, but they are not retroactive. Make sure you look into what version of PHP is compatible with the desired version of WordPress.

This will most definitely affect your plugins and themes. Which is why you may need to roll them back as well.

If you do not, there is a very strong possibility nothing will work.

Security First

Overall, you may find a use for this feature from time to time, but I can assure you that if you are doing this get an old feature back or because you are more comfortable with an older version, it not worth it.

This will significantly lower your website’s security. This not only puts your entire website at risk, but you could also expose personal information of your customers, which is a surefire way to scare them away.

Why are you downgrading your WordPress version? How long do you plan on using an obsolete version of WordPress?

Author: Robert Giaquinto

Robert has been writing tutorials about WordPress and other CMS for over 3 years since joining the GreenGeeks marketing team. Thanks to this, he has had the opportunity to research and master several areas of WordPress including plugin usage, SEO, website design, and social media integration. When he is not creating content for WordPress, Robert is digging up new content ideas for environmental pieces. These range from the pollution in our air to the danger’s wildlife face. And with a bachelor’s degree in electrical engineering, he is always eager to discuss the way our technologies are affecting the environment, especially when it comes to solar energy.

Was this article helpful?

Related Articles

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.